OpenICE Community Support Forum

Welcome to the OpenICE community support forum. Use this forum for submitting bugs, asking for help, and solving problems you are having with OpenICE software. For ideas, general questions, and conversation please use the discussion forum.

artifactiory not accessibile

gianpiero 5 months ago in OpenICE • updated 4 months ago 1


I am trying to build the mdpn repo but it looks like is down. 

This are the error i get:

* What went wrong:
A problem occurred evaluating project ':data-types:x73-idl-rti-dds'.
> Could not resolve all dependencies for configuration ':data-types:x73-idl-rti-dds:rtiddsgen'.
   > Could not resolve org.anarres:cpp-bin:1.2.8-SNAPSHOT.
     Required by:
      > Unable to load Maven meta-data from
         > Could not GET ''.
            > peer not authenticated
      > Unable to load Maven meta-data from
         > Could not GET ''.
            > peer not authenticated
      > Unable to load Maven meta-data from
         > Could not GET ''.
            > peer not authenticated



Jd Dietrich 3 years ago in OpenICE • updated by Gibbons 4 months ago 3
hello, I'm looking into this community as a noob to the EMR, EHR, MD PnP, Payer, Provider etc. There is a lot to wrap my head around.

My questions are more related to how you are interfacing with EMRs, and what format you're pushing that data? From a more technical perspective, are you exposing the data through an API? Or are you publishing that data directly to a system? Would love to get a quick overview, from a quasi-technical perspective.


Jeff Peterson 3 years ago
Hi JD,

Thanks for your question! The short answer is that EMR communication/integration is done through HL7 ( Our preferred HL7 version is the development version of HL7 FHIR ( If you're interested in using HL7 FHIR and java (what OpenICE uses), a fantastic learning resource is the HAPI FHIR project (

We have only begun to experiment with EMR integrations, but our current state is best illustrated by the OpenICE Supervisor app 'HL7 Exporter'. You can use the app by installing OpenICE: And you can check out the code here: The app will take data from the active patient and export it via HL7 at a user defined time interval.

Our HIMSS15 demo app illustrated some mock "auto-validation" of medical device data that was then exported using the HL7 export app to a fake EMR. That system is representative of some of our future development ideas that will be on our roadmap eventually. For now, there is still a lot of work to do in this area...

Feel free to continue the conversation. Thanks,
Under review

Is server down?

jaewon-choi 1 year ago in OpenICE • updated by gianpiero 5 months ago 5

I tried build your mdpnp project(, but it occurs error like below.

It looks your server has some problem(502 error occurs), can you check out this?

Dave 1 year ago

I restarted the server, please try again.


Android Apps compilation is failed

Hank Jiang 2 years ago in OpenICE • updated by vondes 5 months ago 1
I would like to use Android App,but I can not build it.

NOTE: To build with OpenSplice compatibility please set the OSPL_HOME and SPLICE_TARGET environment variables.
Defining custom ‘build’ task is deprecated when using standard lifecycle plugin has been deprecated and is scheduled to be removed in Gradle 3.0

FAILURE: Build failed with an exception.

* What went wrong:
Project 'android-apps' not found in project ':interop-lab'.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 9.311 secs
How could I build it?

Best regards.

Jeff Plourde 2 years ago
Hi Hank

The "android-apps" project was a simple demonstration of connecting directly to the Nonin Bluetooth Pulse Oximeter from an Android device. The project is no longer part of the build since 19-June-2013. It remains in the repo for reference but it has been deprecated since that time.

Thank you
Jeff Plourde

HL7 Export

hc1528 2 years ago in OpenICE • updated by Robertson 5 months ago 1


I has try install OpenICE and successful installed.

I has create simulated device and link to patient (list in patient ID), it look working fine.

I has run HL7 export and start it, but HL7 message has been capture did not show active patient data , why this thing happened?

hope you can help me. thank you


Raspberry Pi

Alejandro Figar 3 years ago in OpenICE • updated by Stephanie Clemens 6 months ago 8
I'm trying to run MdPnP demo app on Rpi. I'm having problems with DDS libraries. I've tried using libraries provided by RTI from the Rpi port. I'm having a segmentation fault:

C [] call_gmon_start+0x7

I hope you could give me some advice.

DDS demo-apps device-adapter

OpenICE with Ethernet

Juhi 6 months ago in OpenICE 0

I am working with beaglebone and philips intelliVue series. The command "echo  -app ICE_Device_Interface -domain 6 -device IntellivueEthernet -address > device.this" is not reading IP_Address. Please help.


IntelliVue MX800 over LAN with Demo Apps

Thomas Drake-Brockman 3 years ago in OpenICE • updated by Andrei Paduraru 7 months ago 12

I've been attempting to connect to our IntelliVue MX800 over LAN with the OpenICE demo apps.

I have established a network connection to the monitor from my laptop successfully, and can ping the device. However, I'm unable to get the device adapter to connect to the monitor over LAN.

I inspected network traffic with Wireshark, and saw no communication at all addressed to the monitor IP that I entered when starting the device adapter.


Using openICE with the MX800

Boaz Yaari 7 months ago in OpenICE 0

Hello all,

I know that this topic has been covered extensively, but I haven't seemed to have any luck for months already. I have been attempting to connect the Phillips MX800 to my computer to collect data from it. I am following the directions exactly, but have no luck at all. The monitor is in the simulation room at the local hospital so I have freedom to play with it at the hospital, but not to bring it to a lab.

I'm not sure at this point if it's an issue with the monitor, and I don't know how to find out if it is or isn't. When I connect directly to the computer with the keyspan tripplite adapter, or when I connect with the beaglebone black with the openICE debian running I can't see any signal, and on the monitor settings I'm going exactly according to the instructions on the phillips manual.

My background in computers and engineering isn't strong (I'm a biology student), but I feel like at this stage I'm missing something and I just can't seem to find what it is. I recently found an intellibridge ec10, but I can't find how to access the data from that either. If somebody could help me I would be extremely appreciative and would be happy to assist in some way too.

Thank you for any assistance in advance, and a big thank you to this community in general for all the hard work put into this project, it's a great tool.


device-adapter ICE OpenICE


maryem 1 year ago in DDS • updated by Anthony Tenison 7 months ago 1


i follow the instruction of the documentation "open DDS 3.9 version .

ACE_ROOT/ace/config.h exists, skipping configuration of ACE+TAORunning MPC to generate project files

this message error appear : can't open perl script , No such file or directoryError from MPC, stopped at configure line 1136.

can you help me ??

Installing OpenICE on Raspberry Pi

Jin Matsumoto 2 years ago • updated by BenCarpenter 8 months ago 1

I'm starting a project using the Raspberry Pi with OpenICE. I downloaded the zip file, but when I try to run the OpenICE script within the bin directory, nothing happens. I am pretty new to RPi so any help would be great. Thank you


MDPnP with Philips MP70 (via RS232)

Nathan 3 years ago in OpenICE • updated by veerendra852 8 months ago 3
Dear MDPnP Group, 

We are currently working on a multi-site study that will be analyzing waveform data recorded from patients in the ICU. We have been purchasing software for each site that allows us to export waveform data to a file that can be analyzed at a later time. Many of our sites have Philips MP70 monitors, however, so it is possible that MDPnP could be used as an alternate means to obtain the data. 

Does the current version of MDPnP allow waveform data to be saved to a file? If not, would it be difficult to modify to permit data export? I would be willing to try some coding myself, if perhaps you could point me to the most reasonable places to start. From another comment on the discussion forum, it sounds like you have export working with MongoDB in your lab. We are looking at using MongoDB for the waveforms in our lab as well, so I would be interested in learning more about this solution.

I also have a comment about the adapter setup example for the MP70 on your website ( ). In your example, you mention that a "Cisco console cable" can be used to connect to the serial port of the Philips monitor. I ordered one, but the cable did not work; later, after I googled the pinout of the Cisco console cable, I noticed that pins 4 and 5 of the RJ45 are typically grounded, but the Philips cable requires pin 5 of the RJ45 to be the Tx->Rx signal for the RJ45->DB9 connection. Perhaps it was a different type of console cable?

We are watching your project with interest in our lab- thank you for all your effort in this area.

Many thanks for your help!

Kind regards,

OpenICE device-adapter
Under review

Error when launching openICE

Imad Eddine 1 year ago in OpenICE • updated by Dylan Bagshaw 9 months ago 2


I'm installed OpenICe on Win7, after starting the application and selecting ICE_Device_Interface, I full fill the flowing information :

1. Device Category --> Simulated

2. Device Type --> Simulated Pulse Oximeter

3. Domain ID --> 15

The application couldn't start with two error messages

1. Error invoking methods

2. Failed to launch JVM

Could you please explain me the causes of these errors.


device-adapter ICE OpenICE

Arterial Blood Pressure not coming in from Intellivue

Jeremy 11 months ago in OpenICE • updated by Dylan Bagshaw 9 months ago 2


I currently have OpenICE connected to an Intellivue MP90. We get the waveform data from the ART BP line but there's we're not receiving any numbers (i.e. Sys/Dia/Mean).

Any idea?

Dylan Bagshaw 9 months ago


Thank you for pointing this out. It appears the adapter for the Philips monitors is not passing this information along to the OpenICE app. However, our GE devices share the MDC_PRESS_BLD_SYS, MDC_PRESS_BLD_MEAN and MDC_PRESS_BLD_DIA in the OpenICE app.

Unfortunately, we currently lack the developer work force to tackle projects like these. Sorry for the inconvenience.



Wireless Devices with OpenICE

Imad Eddine 1 year ago in OpenICE • updated by Dylan Bagshaw 9 months ago 1


Can you please tell me if medical devices can communicate with OpenICE Device-adapter using wireless connections like WIFI, Bluetooth... because in docs they mentionned that the medical device can communicate with OpenICE device adapter just through serial- connection.

My bests


device-adapter ICE OpenICE
Dylan Bagshaw 9 months ago

Please refer to responses on your previous post.

As mentioned, the Nonin bluetooth pulse ox is a wireless device you can use with OpenICE.