0
Under review

openice supervisor does not open

Peter 2 months ago in OpenICE • updated by Dylan Bagshaw 2 months ago 3

openice supervisor does not open although process is running, also geting openice.exe stopped working when trying to enter device setup. Have reinstalled several time. Running on windows 7 pc, java version 8 update 151. Openice installed using windows execeutible file

OpenICE
Under review

Try following the documentation here to build the code from source. Download the .zip containing the source, unzip it, use the command line to navigate to the folder containing the code, build and run.

Hi Dylan,


Happy New Year. I am getting the following errors when I to build.


When i use Gradlew i get;

NOTE: To build with OpenSplice compatibility please set the OSPL_HOME and SPLICE
_TARGET environment variables.
Defining custom æbuildÆ task is deprecated when using standard lifecycle plugin has been deprecated and is scheduled to be removed in Gradle 3.0

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\OpenICE\mdpnp-0.6.3\data-types\x73-idl-rti-dds\build.gradle' line
: 20

* What went wrong:
A problem occurred evaluating project ':data-types:x73-idl-rti-dds'.
> Could not find property 'JAVA_VERSION_SOURCE' on project ':data-types:x73-idl-
rti-dds'.


When i try gradle build i get;

NOTE: To build with OpenSplice compatibility please set the OSPL_HOME and SPLICE_TARGET environment variables.
Defining custom æbuildÆ task is deprecated when using standard lifecycle plugin
has been deprecated and is scheduled to be removed in Gradle 3.0

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\OpenICE\mdpnp-0.6.3\data-types\x73-idl-rti-dds\build.gradle' line
: 20

* What went wrong:
A problem occurred evaluating project ':data-types:x73-idl-rti-dds'.
> Could not find property 'JAVA_VERSION_SOURCE' on project ':data-types:x73-idl-rti-dds'.


Not sure what to do next?


Thanks,

Peter


Hi Peter,


My best guess is to make sure you're java jre is installed correctly and the java environment is properly set up. Line 20: in that build.gradle file is the sourceCompatibilty. Make sure your environment is set for java 1.8.


Here's a link to the build.gradle on GitHub

https://github.com/mdpnp/mdpnp/blob/master/data-types/x73-idl-rti-dds/build.gradle


and a link to a SOF that could help

https://stackoverflow.com/questions/16654951/gradle-sourcecompatibility-vs-targetcompatibility



Dylan