Raspberry Pi

Alejandro Figar 3 years ago in OpenICE • updated by Bach Johann 2 months ago 8
I'm trying to run MdPnP demo app on Rpi. I'm having problems with DDS libraries. I've tried using libraries provided by RTI from the Rpi port. I'm having a segmentation fault:

C [libnddscore.so+0x72d48] call_gmon_start+0x7

I hope you could give me some advice.

DDS demo-apps device-adapter
Thank you Jeff! I'm glad you solve this issue for all of us! 
Satisfaction mark by Alejandro Figar 3 years ago
Under review
Hi Alejandro, thanks for your question!

If you are trying to run the pre-built demo-apps binary (downloaded from mdpnp.sourceforge.net), DDS is included in the binary and should automatically run without further configuration. Essentially, you should not need to use the RTI DDS port in addition running the demo-apps. Try removing the RTI DDS libraries that were added.

Another quick step to try is to unset the NDDSHOME environment variable. To do this, enter "unset NDDSHOME" at the console. This will trigger the Java code in demo-apps to extract its own DDS libraries.

Let us know if this works and if there is anything else we can help with. I look forward to hearing back.
I did as you said. It's true that demo-apps extract its own DDS libraries but sadly It's also true that I couldn't made this work on Rpi. I tried on two different Rpis with two different versions of raspbian Linux and I've got the same segmentation fault as I'd reported on the first post. Is there any Demo-app available that has been already tested on Rpi?

Thank you!

Hi Alejandro,

I just loaded an RPi with Raspbian and demo-apps-0.4.2 and sure enough I reproduced the exact same error. Good find. I will figure something out ASAP and get back to you. Sorry for the inconvenience.


Thanks for sharing nice information with us. i like your post and all you share with us is uptodate and quite informative, i would like to bookmark the page so i can come here again to read you, as you have done a wonderful job. magie et voyance

Hi Alejandro

A root cause for the SIGILL on shared object initialization proved elusive since the instruction in question (CBZ) *should* be legal in the ARMv6 Thumb-2 extensions.  The text segment may have been corrupted or poorly aligned for an unknown reason.  Nevertheless I was able to relink the shared objects in question with ordinary ARMv6 instructions only (-march=armv6) and we have tested the result successfully on Raspberry Pi.  I'll communicate my fix to RTI as well.

Please try version 0.4.3 of our software on SourceForge (which incorporates the fix) and let us know the results.  Thanks again for the feedback!

Jeff Plourde

Hi Alejandro,

I am working on a project involving the RPi and OpenICE and I was wondering if you shed light on how you downloaded OpenICE to the RPi. I am pretty new to RPi so any information would be great. Also, were you able to get run OpenICE successfully? Thank you

i just tried to install openice in my raspberry pi and. My Ubuntu I get error some 502 which route certain url .I tried newer version of openice 0.6

Can any one suggest how can I run the demo